opencpn et antenne active mc marine gp-01

2018 lectures / 12 contributions / 0 nouveau(x)
Hors ligne
SKANES 575
Inscrit forum
opencpn et antenne active mc marine gp-01
sujet n°97234
bonjour
j'ai installé open cpn sur un ordi portable windows 7 ainsi que les cartes cm93 toutmarche bien. j'ai voulu conecter un gps antenne active usb mc marine GP-01.impossiblede le connecter à open . IL indique bien ma position quand il fonctionne avec son logiciel (sky track) mais ne communique pas avec les satellites sous open cpn. j'ai bien suivi leprotocole d'installation, ouverture du port com dans la boite à outils, rien n'y fait. après plusieurs essais, j'ai remarqué le gps  ne communiquait (dans sky track)uniquement avec un baurate de 115200; dans le logiciel opencpnn dans l'onglet NMEA, la vitesse en baud maxi est de 38400.et donc impossible de communiquer comment faire pour la passer à 115200 ? merci beaucoup à celui qui peut me dépanner
Bernard

Hors ligne
SUNSHINE 36 GTE
Inscrit forum
réponse n°175690

C'est curieux, le baud rate annoncé (voir lien) est de 4800 bauds, ce qui paraît tout à fait classique. (La vitesse 38400 est pour l'AIS). Jamais entendu parler d'un baud rate de 115200 !

Installe le driver Prolific PL-2303 (voir lien), un grand classique qui marche avec la plupart des souris USB pour créer un port COM.
Ne lance pas sky track en même temps qu'OpenCpn !!!!
Télécharge Xport ici http://www.curioustech.net/xport.html (plus de ligne en dessous, désolé)('DOWNLOAD 32 bits only...' vers le milieu de la page)
Dézipper et mettre les fichiers et le programme dans un dossier (appelé par exemple Xport) sur le bureau (Ce programme ne s'installe pas !!!).
Branche le GPS.
Doucle clic sur xport.exe
Dans la fenêtre ouverte, faire 'find GPS'. Il trouve automatiquement  le port COM et le baud rate. 
Ferme Xport (X dans le coin haut droit de la fenêtre)
Configure OpenCpn avec ces valeurs , et roule ma poule...

http://www.naturestore.fr/p881/MC-MARINE_GP-01_USB.html

http://www.prolific.com.tw/eng/downloads.asp?id=31

Hors ligne
SKANES 575
Inscrit forum
réponse n°175696

bonjour sailor54
merci pour ta réponse, "j'ai tout fait comme tu as dit", et le xport indique lorsque je le lance ( find GPS) input port ; com 7 (normal) et le baud rate : 115200  ce qui est impossible à installer dans open cpn   ?? quid??? je ne sais que faire
petite precision le maxi indiqué pour le baudrate dans sky track est de 230400   !!! Pourquoi?

Hors ligne
SUNSHINE 36 GTE
Inscrit forum
réponse n°175699

Je suis perplexe.
Contrairement à ce que j'ai dit, en Googlant un peu, il existe des GPS dont le taux de transfert est de 115200.
Mais Discount Marine indique pour ce modèle (MC marine GP-01 un baud rate de 4800 !!!!
Peut-être s'agit-il d'un modèle spécial.
Le logiciel Skytrack permet-il de changer cette valeur ?
Y-a-t-il quelque chose dans une doc ?

En désespoir de cause, fait une copie (de sauvegarde) du fichier Opencpn.ini (dans C:\ProgramData\opencpn), ouvre le fichier avec Notepad (= Bloc Note) et change la ligne
BaudRate=4800 (ou une autre valeur)
en
BaudRate=115200
Enregistre et redémarre OpenCpn avec cette version modifiée de ce fichier et croise les doigts
Si OpenCpn plante, remet la version originale...

Je vais poser la question sur le forum US d'OpenCpn...

PS: je viens de voir que tu peux taper directement la valeur 115200 dans la boîte à outils/GPS. Je viens de vérifier: le fichier opencpn.ini est bien modifié quand on clique 'OK'
Donc inutile de faire la modif avec Notepad.

http://www.discount-marine.com/p5290/GP-01_antenne_GPS_sur_USB.html

Hors ligne
SKANES 575
Inscrit forum
réponse n°175701

je tape la valeur 115200 mais elle ne reste pas même si l'on fait ok le maxi est toujours de 38400 ;  et aussi quand j'ouvre la fenetre d'affichage des données nmea rien ne se passe, pas de communication GPS
de plus je ne trouve pas le fichier ini, peut être il a un autre nom

Hors ligne
SUNSHINE 36 GTE
Inscrit forum
réponse n°175702

D'après ce que j'ai vu, la valeur inscrite dans le fichier .ini est bien 115200 même si elle ne reste pas affichée.

----
Je confirme, si je tape 66666 par exemple, cette valeur se retrouve bien dans le fichier ini
-----
Tente le coup pour voir si cela marche
Tape la valeur, clique OK, ferme et rouvre OpenCpn,  et branche ton GPS

Je ne connais pas Windows 7 mais il doit y avoir un panneau de configuration 'option des dossiers' qui permet de rendre visible les dossiers cachés comme ProgramData; qui contient un dossier opencpn qui contient le fichier opencpn.ini

Tu peux aussi trouver sa localisation dans OpenCpn en appuyant dans la barre des tâches sur le gros point d'interrogation bleu et en regardant dans l'onglet 'A propos d'Opencpn' la derrnière ligne

'Logfile location: C:\ProgramData\opencpn\opencpn.log'
Le fichier opencpn.ini se trouve au même endroit que le fichier opencpn.log

Hors ligne
Van de Stadt 34 (Monocoque)
Inscrit forum
réponse n°175755

Bonjour,

Pour trouver le fichier .ini , dans toutes les versions de windows,voyez dans cette page, sur ce lien :

http://www.eauxturquoises.fr/a_tutopencpn/3_tutopencpn/35/352_Trucs_et_astuces/352_Trucs_et_astuces.htm#3

D'autre part, la norme NMEA 183 fait transmettre les données à 4800 bauds (4800 caractères qui p)ar ailleurs sont codés chacun sur huit bits ). Si certain GPS sont vendus comme fonctionnant à 38400 bauds, il faudrait sans doute comprendre 38400 bits par unité de temps ( 38400 = 4800 X 8 ).

Et 115200 ... ???? Ce n'est pas dans la norme NMEA 183.

Cordialement

Gilletarom.

Hors ligne
GOÉLETTE
Inscrit forum
réponse n°175756

Bonjour tous,

ce n'est pas un problème de la souris GPS MC Marine GP 01 (et autres), ni d'OpenCPN sous Win XP Pro. J'ai testé : tout est O.K. immédiatement une fois installée le driver du GPS (Prolific) et reconnu le port série émulé USB (N° 1 à X selon PC) et configuré à 4800 bds / 8 bits, parité none, etc..

Donc chercher plutôt du côté de Win 7, de Sky machin, des entrées/sorties (I/O) du port série attribué et ouvert (il faut souvent le "forcer") ...

Vérifier que les phrases NMEA défilent bien dans le fenêtre qu'on ouvre par la petite appli (GPSView je crois) contenue dans le petit CD d'installation de la souris GPS MC marine GP-01.


Hors ligne
SKANES 575
Inscrit forum
réponse n°175770

rebonjour,
c'est encore moi , après une petite interruption, je reprends mes essais et merci à tous ceux qui m'aident ;voici le point de la situation
dans open ini, le baudrate reste bien à115200 ; open ne communique  toujours pas avec le gps
le driver du gps prolific est bien installé, reconnu ( chez moi port com 7),  lorque j"ouvre la petite fenêtre dans la petite appli gps view,
les phrases nmea ne sont dans la dite fenêtre que lorsque le baudrate est sur 115200,et à ce moment là, j'ai les coord gps sur l'appli, alttitude etc, quand je programme d'autres baudrates , je n'ai plus de phases nmea : aucune information....
par contre, j'ai tenté un autre essai; désinstallation du driver puis re-installation et quand je lance open, il indique : impossible d'ouvrir le port com7,le  gps est il   branché, le  cable provenant de la source de l'ais etc, etc......
je comprends bien que c'est un probleme de configuation et je ne sais plus où chercher, comment peut on forcer l'ouverture du port7

Hors ligne
SUNSHINE 36 GTE
Inscrit forum
réponse n°175771
Saintex31 a écrit :

1 - dans open ini, le baudrate reste bien à115200 ; open ne communique  toujours pas avec le gps
le driver du gps prolific est bien installé, reconnu ( chez moi port com 7),  lorque j"ouvre la petite fenêtre dans la petite appli gps view,
les phrases nmea ne sont dans la dite fen^tre que lorsque le baudrate est sur 115200,et à ce moment là, j'ai les coord gps sir l'appli, alttitude etc, quand je progrmma d'autres baudrates , je n'ai plus de phases nmea : aucune information....

2 - parcontre, j'ai tenté un autre essai; desinstallation du driver puis reinstallation et quand je lance open, il indique : impossible d'ouvrir le port com7,le  gps est il   branché, le  cable provenant de la source de l'ais etc, etc......
je comprends bien que c'est un probleme de configuation et je ne sais plus où chercher, comment peut on forcer l'ouverture du port7

 Message annulé, voir le suivant...

Hors ligne
SUNSHINE 36 GTE
Inscrit forum
réponse n°175817

Je pense avoir compris.

Ce GPS est en mode SIRF (haut débit binaire), et non en mode NMEA.

Je suggère de télécharger et d'installer SIRFdemo (setupSiRFDemo3.87.zip) à l'adresse ci-dessous

J'ai réussi à faire passer mon GPS du mode NMEA 4800 bauds  au mode SIRF à 57600 bauds, puis à revenir au mode NMEA, mais à 9600 bauds, ce qui est OK avec OpenCpn

Lancer Xport, faire 'Find GPS', noter le port (par exemple 4) et la vitesse (sans doute 115200)
Choisir un autre port dans la colonne de droite (cliquer sur le petit volet avec un triangle) et parcourir la liste) (par exemple 11) (voir image1) et cocher 'enable ports' (un bouton rouge doit s'allumer) (voir image 2)

Lancer Sirfdemo en laissant Xport ouvert
Menu data source: choisir cet autre port (11) avec la vitesse indiquée par Xport (sans doute 115200)
Menu Action : Open data source
Les valeurs devraient défiler....
Si oui,
Menu Action, 'switch to NMEA protocol'
Dans la fenêtre qui s'ouvre, cliquer sur 'set default', puis 'send'
(dans Xport: 'Find GPS' doit maintenant trouver le premier port (4) avec une vitesse lente (9600 bauds))
puis
Menu Setup, Data Source, choisir l'autre port (11), puis vitesse trouvée par Xport  (9600 bauds)
Menu Action, Open Data Source
et les valeurs devraient défiler.
Fermer Sirfdemo et vérifier avec OpenCpn en choisissant l'autre port (11)

http://www.falcom.de/support/software-tools/sirf/

Hors ligne
Feeling 32
Inscrit forum
réponse n°239625

 Bonjour,
ce GPS est bien en NMEA 4800 bauds. Il fonctionne très bien sur mon MAC avec openCPN. Le driver est à prendre sur le site web du fournisseur. GPS très performant et précis. Attention ce n'est pas une souris.
La question est assez ancienne sur ce fils, mais comme la réponse finale n'est pas correcte , je me permet de compléter.


Le site de la Grande Croisière...