curieux .. .gps en simulateur

1518 lectures / 13 contributions / 0 nouveau(x)
Hors ligne
VOILIER
Inscrit forum
curieux .. .gps en simulateur
sujet n°96259
Bonjour

Je mets mon gps en simulateur, route au 310, carte raster, openCpn 2.3.1.
Une trace se fait, MAIS, la droite qui prolonge le bateau est angulée par rapport à la route.
Allez, la barre au 270. Tiens, la route et la droite sont alignées !
barre au 260, angulation. barre au 180, c'est aligné :/
Bref 0, 90, 180, 270 les routes et la projection concordent, pas les autres routes/caps.
D'où cela peut-il venir ?

Merci d'avance pour votre éclairage.
Hors ligne
VOYAGE 12.50
Inscrit forum
réponse n°170534

Salut
D'humeur taquine je te dirais bien que tu as une forte dérive au vent et au courant.... Non ???
Plus sérieux, je n'arrive pas lire ta deuxième copie d'écran
Cordialement
Michel

Hors ligne
VOILIER
Inscrit forum
réponse n°170598

Bonjour Yoruk, merci de ta réponse.

La seconde image est la maman de la première, la même situation plus large, mais le téléchargement ne se réalise pas.

Taraudé par le problème, j'emet l'hypothése que les échelles horizontale et verticale sont différentes (normal).
Un des vecteur, (la trace par exemple) serait calculé par positionnement dans l'espace des coordonnées (on est à telle position latitude/longitude et on va à telle autre position) alors que l'autre vecteur (la projection vers le futur) serait simplement un angle depuis la position actuelle. Je m'appuie sur le fait que les caps 0, 90, 180 et 270 font que les 2 vecteurs sont conformes.

Mmmh, pas sûr d'avoir été clair ...

Hors ligne
VOYAGE 12.50
Inscrit forum
réponse n°170605

Bonjour
Pas de chance avec moi, tu es tombé sur le ‘manuel’ du groupe… Néanmoins, je me tiens soigneusement informé du travail intellectuel de mes copains du tutoriel.
A ce titre, on bosse sur le fichier opencpn.Ini, sur lequel quelques ‘pointures’ *** sont venus fort aimablement nous donner un coup de main.
Donc à ce titre, il est possible que ton problème relève de la variable d’enregistrement
Textuellement :

Temps (en secondes) utilisé pour calculer la moyenne glissante du cap réellement suivi, utilisée pour le calcul d'orientation de la carte quand le mode 'Cap vers le haut' est activé. Permet de stabiliser la carte, et éviter ainsi les mouvements de rotation incessants. Cette valeur par défaut n'est pas modifiable par menu.

Or, à la lecture de ton image, plus haut, il semble que le bateau sort d’une zone cartographiée différente. Peux-tu tester une route, un cap et une trace sur une zone homogène, en diminuant le temps (où la distance) des enregistrements ??? (dans la boite à outils, dans etc… marquer les points de trace toutes les xxx secondes)
Cordialement
Michel

*** Pointure n'est pas péjoratif... on a vu arriver, pour ce tutoriel, en conseil et en appoints techniques, des experts reconnus, experts et marins... Ce qui nous rééjoui particulièrement

Hors ligne
VOILIER
Inscrit forum
réponse n°170657

Mouiiiii

Bon je me fabrique un cable croisé dès que possible, puis je monterais un "banc de test" avec un simulateur.
Là, je l'ai fait avec un GPS à main, lequel démarre n'importe où sur la planète. Il faut que je me mette à 999k avec un cap pifométrique pour arriver sur une carte en ma possession.

Hors ligne
VOYAGE 12.50
Inscrit forum
réponse n°170658

Ok
Tu nous tiens au courant
Michel

Hors ligne
VOILIER
Inscrit forum
réponse n°171252
Yörük a écrit :
Tu nous tiens au courant

 Bonjour Michel. Ok, mais je n'ai pas de module "courant" :D

J'ai donc relié les 2 ports série de la machine par un cable croisé. Aucun problème.
Vu la lourdeur de la simulation par mon gps à main, j'ai cherché des logiciels de simulation de GPS.

Je n'ai rien trouvé de probant. Ils ont tous des limitations rédhibitoires.

Si vous avez des solutions de sumlateur, je suis preneur.

Quant au problème initial, je dois refaire la manip, je m'étais loupé, mais il semble que le problème est résolu. Juste semble.

Hors ligne
FEELING 1090
Inscrit forum
réponse n°171336

Bonjour,

je pense avoir une solution à ta recherche de Simulateur GPS.
J'en avais besoin d'un pour faire un cours sur OpenCPN dans lequel je veux faire une démo du bateau qui suit une route.
Pour cela, j'utilise un simulateur GPS dans lequel j'ai défini une trace de quelques waypoints.
Le résultat de la simulation dans cette photo.

Le simulateur s'appelle GPSGate Client, en libre service pour 15 jours. Voir l'url. Il est très simple à utiliser:
1. Se mettre en mode Simulation
2. Définir un port Com virtuel de sortie (Com6 par exemple)
3. Définir les waypoints un par un (un peu laborieux, mais son format de fichier est différent des .gpx)
4. Start (pour lancer la simulation)
5. Configurer OpenCPN comme si le GPS était sur le port série Com6)
Magnifique ! On voit le bateau se déplacer avec sa trace (rouge) en suivant la route (bleue) que j'avais créée dans OpenCPN, dans un petit archipel connu de tous !  Pour rendre la démo réaliste, j'ai évidemment provoqué des écarts de route de notre barreur distrait.

Bon courage,
Gérard.

http://gpsgate.com/products/gpsgate_client

Hors ligne
VOILIER
Inscrit forum
réponse n°171358

Bonsoir, et merci de ta réponse.

Avec un simulateur, le problème disparait. Merveilleux.

Concernant les simulateurs, aucun ne m'a satisfait. Ou ils sont limités dans le temps ou dans les fonctions.
Toutefois, capCode, excellent logiciel pour l'entrainement, possède un simulateur, pas top dans les fonctions, mais suffisant.
Le problème, c'est qu'il termine mal les phrases NMEA, donc, les logiciels n'arrivent pas à le comprendre ...

Hors ligne
BENETEAU IDYLLE 11.50
Inscrit forum
réponse n°172006

j'ai windows seven et il ne reconnais pas ma souris GPS est ce que vous avez eu ou avez ce probléme et quelle est la solution ?
merci par avance
@ + El Gringo26

Hors ligne
VOYAGE 12.50
Inscrit forum
réponse n°172012
El gringo a écrit :
j'ai windows seven et il ne reconnais pas ma souris GPS est ce que vous avez eu ou avez ce probléme et quelle est la solution ?
merci par avance
@ + El Gringo26

 Salut
J'ai eu le problème avec XP pour une antenne GPS USB Garmin.
C'était un défaut de pilote. Il m'a fallu trouver le bon pilote. Depuis, plus aucun problème
Cordialement
Michel

Hors ligne
BENETEAU IDYLLE 11.50
Inscrit forum
réponse n°172471

OK je te remercie avec retard .... j'ai réglé le probléme en insistant un peu
merci encore
El Gringo 26

Inscrit forum
réponse n°173793
Bmayer a écrit :
Bonsoir, et merci de ta réponse.

Avec un simulateur, le problème disparait. Merveilleux.

 avec du retard à l'allumage, concernant les simulation :

NavMonPc permet de réaliser une simulation de route. Et le site du logiciel fournit un fichier (unique malheureusement) pour le faire tourner.

Voyez ici les détails de la mise en oeuvre sur ce lien :

http://www.eauxturquoises.fr/a_tutopencpn/3_tutopencpn/35/352_Trucs_et_astuces/352_Trucs_et_astuces.htm#5

Cordialement

Pour loe collectif, Gilletarom

Le site de la Grande Croisière...