Open cpn / antenne GPS

1118 lectures / 16 posts / 0 new
Offline
GIN FIZZ
Forum member
Open cpn / antenne GPS
subject no 108552
Bonjour,
J ai sur mon veil ordi la version Opencpn 2.2 qui marche parfaitement sous XP avec une antenne Gps conectée par usb.
Je viens d'acheter un nouvel ordi, qui tourne sous windows8.
Premierre chose, je dois démarrer l'ori avec l antenne branchée pour qu'il la reconnaisse.
Deuxiemement, mon bateau s'affiche bien en rouge donc le GPS est reconnu mais il ne me donne pas la position. Celle qu il me donne est du coté de la novelle Zélande, lieu ou l 'antenne a étée débranchée.
Si quelqu un a une idée du problème........
Bon vent a tous
Offline
Forum member
answer no 236985

Bonjour,

J'ai eu un peu le meme problème avec une antenne GPS BU354S4 connectée par USB.  Aucun problème sous XP, mais elle n'était pas reconnue sous Windows 7. Après installation du pilote à partir de la disquette fournie avec le GPS, celui-ci a été reconnu. Il faut alors indiquer dans la partie Options / Connexions de OpenCpn le port COM sur lequel est branché le GPS.

Peut être peux tu faire la même chose ? Si tu n'as plus la disquette tu peux aller chercher le pilote dans le site internet du constructeur.
Le seul souci qui pourrait rester est que celui-ci n'a pas encore écrit de pilote pour Windows 8.

Offline
VOYAGE 12.50
Forum member
answer no 236990
Offline
PRINCESS 33
Forum member
answer no 237009

 si le port est reconnu dan OpenCPN , mais que la position résultante est erronée, c'est probablement une question de configuration du port COM (réel ou virtuel) dans l'ordi, qui n'enregistre pas bien les données NMEA

Aller à la configuration du port et voir vitesse, bit de parité, etc..

Offline
VOYAGE 12.50
Forum member
answer no 237027
Danielloui a écrit :
 si le port est reconnu dan OpenCPN , mais que la position résultante est erronée, c'est probablement une question de configuration du port COM (réel ou virtuel) dans l'ordi, qui n'enregistre pas bien les données NMEA

Aller à la configuration du port et voir vitesse, bit de parité, etc..

 N'importe quoi...
Si le GPS s'affiche en rouge c'est qu'il est inactif... C'est tout simple...
Il y a trois excellents tutoriels pour OpenCPN

  • Shoreline de Giletarom... très complet mais touffu
  • Eauxturquoises plus basique mais facile d'accès
  • Plaisance Pratique avec deux niveaux d'expertises

C'est là qu'il faut aller voir

Michel

Offline
PRINCESS 33
Forum member
answer no 237035
Yörük a écrit :

Si le GPS s'affiche en rouge c'est qu'il est inactif... C'est tout simple...
Il y a trois excellents tutoriels pour OpenCPN

 sauf que j'ai bien lu l'énoncé du problème : le bateau s'affiche en rouge, nous dit le demandeur  ; et les figurent que tu as jointes montrent bien que, dans ce cas, le GPS est actif.

Donc le GPS est actif ; maintenant, il faut analyser les phrases NMEA qu'il transmet ; et si ces phrases sont correctes, il faut chercher dans l'interprétation faite par le logiciel. 

Je ne suis pas certain (sous réserves) que les différents tutoriels traitent de cette question.

Offline
VOYAGE 12.50
Forum member
answer no 237038
Danielloui a écrit :
Yörük a écrit :

Si le GPS s'affiche en rouge c'est qu'il est inactif... C'est tout simple...
Il y a trois excellents tutoriels pour OpenCPN

Je ne suis pas certain (sous réserves) que les différents tutoriels traitent de cette question.

 C'est prudent de prendre des réserves, çà peut permettre de manger son chapeau sans s'étouffer

Pour le traitement du problème du GPS USB ( selon toute vraisemblance un BU 353) voir ce lien

Pour l'état du GPS voir la copie jointe d'un 4ème tutoriel; et même pour un daltonien... Il faut que le logo soit vert pour quand le GPS soit actif

Michel

NB Par ailluers, à l'ettention de l'auteur du fil: il serait prudent de mettre à jour la version d'OpenCPN, la v 2.2 s'est largement dépassé, et je suis pratiquement certain qu'elle ne prend pas les mèj de W7/8... La dernière version 3.2.2 fonctionne perfaitement

Offline
PRINCESS 33
Forum member
answer no 237039

 @ Michel

C'est fou ce qu'on peut être quelquefois bloqué sur une idée fixe !

le demandeur (je cite) écrit : mon bateau s'affiche bien en rouge donc le GPS est reconnu ; il ne nous parle pas du voyant au coin à droite qui peut être rouge ou vert

ça me semble clair !  A toi de manger ton chapeau...

Offline
VOYAGE 12.50
Forum member
answer no 237043
Danielloui a écrit :
 @ Michel

C'est fou ce qu'on peut être quelquefois bloqué sur une idée fixe !

le demandeur (je cite) écrit : mon bateau s'affiche bien en rouge donc le GPS est reconnu ; il ne nous parle pas du voyant au coin à droite qui peut être rouge ou vert

ça me semble clair !  A toi de manger ton chapeau...

 Je le mange... avec des circonstances atténuantes... Je suis daltonien

Pour en revenir au sujet, un peu plus tard je reparlerai des contrôle des phrases NMEA, là j'ai de l'époxy en chantier 

Michel

Offline
PRINCESS 33
Forum member
answer no 237045

 OK, tu es tout excusé

Nous sommes maintenant d'acccord qu'il y a un problème soit :
 - sur les phrases NMEA elles-mêmes : et là on peut soupçonner les paramètres du port COM ; mais inversement on peut intuitivement penser que si OpenCPN reçoit des sentences NMEA, le port COM est correct.
 - soit sur l'interprétation qui en est donnée par le logiciel , et là ça serait plus grave ; mais tu as raison de soupçonner la compatibilité de cette version de OpenCPN avec W8.

A toi de jouer

Offline
VOYAGE 12.50
Forum member
answer no 237053

C’est aussi peut être un problème de paramétrage du GPS. Il faut absolument qu’il soit réglé pour émettre ces 4 phrases :

  • GGA
  • GLL
  • RMA
  • RMC

OpenCPN doit pourvoir lire ces phrases

  • HDM - Heading, Magnetic
  • HDG - Magnetic heading, deviation, variation
  • HDT - Heading, True
  • RMB - Recommended Minimum Navigation Information
  • RMC -Recommended Minimum Navigation Information
  • WPL - Waypoint Location
  • RTE – Routes
  • GGA - Global Positioning System Fix Data
  • GLL - Geographic Position, Latitude / Longitude
  • GSV - Satellites in view
  • VTG - Track Made Good and Ground Speed

Voir ces liens

On contrôle leur réception sous OpenCPN, dans la boite à outil > connexions > Ouvrir la fenêtre d’affichage des données NMEA
Si le GPS reçoit et expédie correctement, les sentences NMEA on devra avoir un affichage des données comme l’image ci contre

Si les sentences NMEA ne passent pas… Dans l’ordre

Pour mémoire, et par correction, le site de Giletarom : opencpn.shoreline.fr/Tutoriel.htm

Cordialement
Michel
NB en priant de ma faire pardonner ma montée rapide dans les tours… mais, le breton est ainsi… Maintenant je retourne à ma gamelle d’époxy…

Offline
GIN FIZZ
Forum member
answer no 237070

Bonjour,
Merci pour toutes vos réponses.
Je n'ai pas eu trop le temps de travailler dessus mais je vais m'y mettre ce weekend.
Le site de Goletarom a l'air parfait;
je vous tiendrais au courant.
Bon weekend

Offline
GIN FIZZ
Forum member
answer no 237465

Bonjour,J ai trouvé la solution un peu tardivement mais elle est tres simple: j' ai acheté une antenne BU 353 S 4 en remplacement
de la BU 353.
Et tout fonctionne bien a présent.
Merci a ceux qui ont pris du temps pour m'aider.

Offline
VOYAGE 12.50
Forum member
answer no 237468
Pierre Jo a écrit :
Bonjour,J ai trouvé la solution un peu tardivement mais elle est tres simple: j' ai acheté une antenne BU 353 S 4 en remplacement
de la BU 353.
Et tout fonctionne bien a présent.
Merci a ceux qui ont pris du temps pour m'aider.

 C'était probablement un problème de mise à jour du pilote

Michel

Offline
JEANNEAU SUN ODYSSE 36 i (Monocoque)
Forum member
answer no 289612
Bonjour,
7 ans après je reprends ce fil, ayant le même genre de problème: indicateur de GPS= 3 barres vertes, icone bateau passe du gris au rouge lors de l'acquisition de la position.
Le positionnement se fait correctement au départ, La trace du bateau  se fait pendant quelques secondes, puis s'arrête et la ligne de foi disparait. La position est bloquée.
j'utilise un portable Asus, W10    , Opencpn 5.2, avec  une antenne "GPS Recever USB" (sans marque, pilote Prolific).   J'ai fait une mise à jour du pilote  et suis revenu à la version 2017. Aucne différence.
J'ai bien le défilement des phrases NMEA (voir PJ). Je n'ai le gps actif qu'avec une vitesse de 9600 bauds.
Mon système marchait    parfaitement  en octobre  2020....
A part une mise à jour de  W10  qui poserait problème je ne vois pas où chercher.  A moins que mon antenne ait rendu l'ame partiellement??
Merci d'avance pour un éclairage avisé.
Michel
 
Offline
JEANNEAU SUN ODYSSE 36 i (Monocoque)
Forum member
answer no 289613

Je m'y suis mal pris avec les PJ....

Le site de la Grande Croisière...